user_mobilelogo
Welcome, Guest
Username: Password: Remember me
This is a public forum thread open to all users
  • Page:
  • 1

TOPIC: My Lido

My Lido 1 year 6 months ago #40246

  • NRG
  • NRG's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 110
  • Thank you received: 23
As promised (Andy!) here’s some info on my Lido. Bit of a long tale!

Background, I’ve always wanted an x19 after seeing one parked in my works car park back in the early ‘80s. The car was a Lido with the reg DD7....which looked like 007. I left a note on the windscreen offering to buy it but the owner had only just bought it, I was smitten but never made any effort to find another...maybe the rebuild of a Dolomite Sprint at the time sucked up my time and money. Roll on some 36years later and heading into retirement I started to hunt around for an early, preferably a Lido car.

Couldn’t find one so ended up buying a one owner ‘88 1500 locally which really had not been looked after at all. That was back in May and I’ve spent the summer reversing 30 years of neglect at considerable expense, truly a new car one part at a time...then out of curiosity one Saturday night after too many beers(!). Google found me a Lido for sale from a dealer in Darlington.

Now I already have two Alfa’s, a Sud Sprint ‘82 and a GTV6 ‘83...my ‘retirement’ x19 an now I was looking at another car. Let’s just say the negotiations with my better half knock the brexit negotiations into a cocked hat! The government have no idea what hard negotiators are LOL.

We’ve had the car 2 months now, it was subject to a major restoration about 4 years ago but I think in the interim it seems to have suffered neglect and suffered from a somewhat less than perfect restoration.

I’m aware this car may be known to the forum and club, however, I’ve found and corrected a lot of minor and not so minor issues with the car which, being a bit of a fussy old bugger with an engineering background, would have expected to have been done correctly the first time around.

Anyhow, there is a bit of a rust issue reappearing and a number of snags that I still need to correct, but the car now drives as it should and is a real pleasure. Some pics as I’ve prattled on long enough.
Attachments:
The following user(s) said Thank You: Andy Rowley

Please Log in or Create an account to join the conversation.

My Lido 1 year 6 months ago #40249

Interesting and entertaining read, Lido looks a beauty.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.070 seconds